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1.0 Overview 

FireNET graphix is a software program that allows a PC to display events in text and/or graphical form as they occur 
on the FireNET fire alarm system.  Up to 64 FireNET control panels may be connected to a PC running FireNET graphix. 
FireNET graphix also allows a user to take control of the fire alarm system via a replica of a fire alarm control panel 
presented on the PC display.  FireNET graphix records all events from the fire alarm system and allows these events to 
be filtered and presented for analysis in a variety of ways 

To connect a FireNET fire alarm system to a PC running FireNET graphix software, a dongle device must be installed in 
one of the control panels and connected to a serial port on the PC.  If the fire alarm system consists of more than one 
fire control panel, information from the other control panels is transmitted over the fire alarm network to the panel 
that is connected to the PC. 

Each dongle is protected by a security code.  This code is assigned by Hochiki America Corporation.  After the security 
code has been entered, it will only work on the FireNET panel on which it was originally installed.  Please see section 
2.4 of this manual for details on obtaining and entering the security code. 

The FireNET graphix system can be connected to a single fire alarm control panel or a network of control panels by up 
to 3,900 feet (1,200 metres) of suitable RS-485 data cable. 

If the FireNET graphix host computer is connected to a Local Area Network (LAN), the FireNET graphix system may be 
further enhanced by use of FireNET graphix workstation displays.  Up to 15 FireNET graphix workstations can display 
events and control the FireNET network.   

For more details on using FireNET graphix workstations, please contact Hochiki America Corporation. 

1.1 Installing the hardware 

The hardware consists of two parts; the dongle circuit board (PCB) which is installed in a FireNET control panel, and 
the RS232/RS485 converter which is located at the computer. 
The dongle provides an isolated interface to the FireNET panel and allows the data from the FireNET graphix 
application to be sent and received.  The FireNET graphix software cannot communicate with the fire panel unless a 
dongle has been installed and the security code has been enabled. 
The dongle is supplied with a ribbon cable to connect it to the FireNET display board.  The dongle must also be 
provided with 24 VDC operating power.  This can be provided by the FireNET control panel auxiliary power. 

NOTE: To avoid damage to the dongle and other equipment, all connections must be made while AC power 
and batteries are disconnected!  

After removing power at the control panel, install the dongle circuit board in the accessory module location in the 
FireNET enclosure.  The accessory module location is to the right of the main board; four standoffs are provided to 
install the dongle.  Next, connect and route the 10 way ribbon cable from the dongle to J5 on the front board of the 
FireNET panel. Once in place, the ribbon cable should be secured with the self-adhesive clips provided. 

Connect the red power wire from the dongle to the Aux 24V + terminal on the FireNET panel (terminal 18). 
Connect the black power wire from the dongle to the Aux 24V - terminal on the FireNET panel (terminal 19). 

A 4-CORE data cable suitable for RS-485 data communications should be installed between the FireNET panel and the 
PC. This data cable should be connected to the terminals marked T+, T-, R+ and R- on the dongle. 
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1.2 PC Connection 

The hardware supplied with the FireNET graphix dongle includes an RS232/RS485 converter.  The RS232/RS485 
converter enables data to be transmitted over greater distances than the few feet possible with an RS232 connection. 
It also provides isolation between the power supply of the PC and that of the FireNET panel.  The converter plugs into 
the 9 pin serial port at the back of the PC.  

The dongle will not function until the FireNET graphix software is installed and a valid security code is obtained from 
Hochiki America Corporation.  See section 2.4 of this manual for details on obtaining and entering the security code. 

Connect the data cable from the FireNET panel as follows: 

 Converter Terminal Panel Dongle PCB Terminal 
+ XMT R+
-  XMT  R- 
-  RCV T- 
+ RCV  T+ 

The data cable should be secured to the converter using the cable clamp and routed such that it is not likely to be 
stressed. 

Data cable to panel/dongle 
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The data converter has two internal PCBs, each with a 4-poisiton DIP switch. It should not be necessary to change 
these switches from the factory default settings, which are as follows –  

MAIN BOARD DAUGHTER BOARD 

Switch 1 ON Switch 1, 2 OFF 
Switch 2, 3, 4 OFF Switch 3, 4 ON 

The converter plugs into a COM port on the PC.  The position of the COM port(s) on 
the rear of PCs differs widely, but there are normally two D type connectors; the 
RS232/RS485 interface module should be plugged into the 9 pin connector and 
secured with the mounting screws provided. 

Alternatively, if the computer does not have a RS232 serial port available, then a 
USB to RS232 serial port conversion device may be used. The Kentec U187 part may 
be used to provide a RS232 data source from the USB port of the computer but in 
this case it is better to use the B3821 USB to RS422 converter detailed below.  

When using the USB to RS422 converter, connect the supplied USB cable to the 
converter and to the PC USB port and connect the data cable from the fire panel 
as follows: 

USB /RS422 Converter Terminal                  Panel Dongle PCB Terminal
                 TXD+                                                            R-
                 TXD-                                                             R+
                 RXD+                                                            T-
                 RXD-                                                             T+              
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1.3 Software Installation 
PC requirements (minimum) 

Processor - Pentium®-class processor, 600 MHz or higher 

Graphics card – 32Mb or better 

Monitor – Set to 1024 x 768 resolution minimum 

Operating system - Windows® 2000/XP  (Control panel, user accounts, Select User, 
properties, Group Membership, select Standard User). 

CD Rom media - CD-ROM or DVD drive  

Disk space - 25MB of free disk space for installation (20 GB recommended if many maps are to be used) 

Memory - 256MB of RAM 

………………………………………………………………………………………………………………………………………………………………………………………………… 

To install FireNET graphix, insert the CD into the CD ROM drive of the PC and wait for the installation to start. Follow 
the setup instructions and click “next” when prompted unless you wish to change any of the file locations chosen by 
FireNET graphix as default (not normally necessary). 

Click “Finish” after FireNET graphix has installed successfully. 

There will now be a new program group (FireNET graphix) displayed when “Programs” is selected from the Windows® 
start menu.  Six options are contained within this program group, including an option to uninstall FireNET graphix 
should you wish to do so. 

The options contained within the FireNET graphix program group are as follows: 

BMPGrabber.exe 
This is a utility for use with FireNET Designer which allows .dxf and .dwg drawing files to be converted to bitmap 
format for use with the FireNET graphix program.  Please see section 4.0 of this manual for more details. 

Designer.exe 
The designer program is used to produce project files to be used with FireNET graphix Run.exe.  You will use 
Designer.exe to create new projects, to select and edit images, import a project file from Loop Explorer, draw map and 
zone links, place and set up device icons, and configure event messages.   

FireNET graphix Manual 
This manual is installed with the program for reference. 

FireNETEventLog.exe 
FireNET Event Log.exe is a utility that allows you to filter the event log by date, event type, device type, user or 
address. The filtered report can be viewed as an HTML file or as a list, and the log can be printed or saved as a .csv or 
text file. 

Run.exe 
This is the main monitoring application that runs on the PC connected to the control panel to display events to the end 
user. 

Uninstall FireNET graphix 
This option allows you remove the FireNET graphix program from the PC. 

FireNET graphix Manual, revision 2.1 Page 5a of 26
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2.0 FireNET graphix Run 

2.1 Running FireNET graphix  

To become familiar with the FireNET graphix system, a simulation mode is provided.  The simulation mode will allow 
you to generate simulated events and observe how the software responds.  The simulation mode can be used with any 
graphix project file (.prj file). 

To operate FireNET graphix in simulation mode click on the Windows® start button.  Select ‘Programs > FireNET 
graphix > Run.exe’.  The FireNET graphix Logon dialog box will be displayed. Click on the User Name field and select 
Administrator. Enter firenet (lower case) as the password and then click the Log In button.  The main graphix 
software window will be displayed. 

Click on the FireNET button in the bottom left of the screen and select FireNET Setup > FireNET Settings from the 
menu. The FireNET graphix settings box allows you to designate a design project (.prj) file.  Click on the Find button, 
select the desired project file and click Open.  The project file will be loaded.  To start the simulation, click on the 
‘Start Simulation’ button.  The settings box will disappear and an ‘Event Simulation Mode’ box will be displayed.  This 
box allows you to generate events based on devices associated with the project file. 

Select a device using the Event Simulation Mode box and click on the Activate button.  Graphix will display the event 
in the event pane, and will also zoom to the device location on the appropriate map (based on project design). 
Multiple events can be created in this way.  As a new event is generated, graphix will add the new event to the event 
pane list of current events 

Deactivate the event by clicking on the Stop button in the Event Simulation Mode box.  The current event list will 
update to show that this event is no longer active.  The event(s) must still be accepted to clear them from the list. 
You may enter a descriptive note in the user comments box and then click on the Accept button to clear the event. 
Note that each event can have its own comments added which will be logged with the event.  Select each event from 
the current events list, enter some details about that event and then accept the event.  It is not necessary to add any 
comments before accepting an event, and there is an ‘Accept All’ button that will accept and clear all non-active 
events. 

If there are multiple current events that span multiple maps, you can locate a device on a map by selecting it on the 
current events list, and then clicking on the Find button.  The Find button is located at the top of the event pane. 

To stop the simulation, click on the FireNET button in the bottom left-hand corner of the screen and select Shutdown 
FireNET. 

The simulator mode provides a convenient way for you to test a project file during the design stage and prior to setup 
and installation of FireNET graphix at the site. 
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The “Site Map” button (top left corner of screen) will always return the display to the default image. This same image 
will also be shown when there are no active events on the system and all events have been accepted. 

The “Zones” button will display a grid array showing the status of all the detection zones configured on the system. 
When in this screen it is possible to select and disable a zone. It is also possible to jump to the “Devices” status grid 
array from this screen. 

The “Devices” button will display a grid array showing the status of all the detection devices configured on the 
system. When in this screen it is possible to select and disable a device and to retrieve the analog values of detection 
devices (note: Get Analog Values does not work in simulation mode). It is also possible to jump to the “Zones” status 
grid array from this screen. 

The “Event Log” button will launch the Event Log viewer application. This will allow the event log to be displayed and 
filtered. The results of the event log search may be displayed as HTML or as List format.  Note that the simulator 
events are logged separately (Sim Log) from actual panel events (Event Log). 

The “Silence Computer” button will silence any audible notification of an event on the computer.  Different audio files 
may be played for different event actions using the computer audio system. 

The “Send Message” button will open the message entry screen. This allows the current user to automatically display 
a message when the message recipient logs on to the FireNET graphix system. Typically this is used to pass 
information to other users, such as reasons for disablements. 

The “Navigate” button will open the navigation form. This allows simple navigation around the images by use of 
“North / South / East / West / Up / Down” buttons. This is particularly useful when the site has a large floor layout as 
it avoids having to zoom out to a higher level map to view other parts of the building. 

Along the lower edge of the Run program display there are a number of status boxes. These status boxes represent 
each type of event that may be displayed on the FireNET system, such as Fires, Pre-alarms, Troubles, Disablements, 
etc. Whenever there are any active events on the system, the appropriate status box will be highlighted in the 
configured color for the event.  In addition, the number of events of that type will be shown. By clicking on the box 
more details can be displayed.  The status boxes may be configured to indicate zone status rather than event status.   

If you click on the links on the site map, you can zoom to a floor level image (note: map links are configured in the 
design stage).  Detector icons are usually placed on the floor level image maps.  Clicking on a detector will open the 
device details screen. Using this screen it is possible to disable the device, poll the device analog value, and view the 
device event history and the current state of the device.  
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If a map link has a zone allocated to it, then it is possible to right click on the link and disable and re-enable the zone 
using this link. 

Now that we have seen the basics of what the system can do we can explore the setup in more detail. 

2.2 FireNET graphix Settings 

Click on the FireNET button in the bottom left of the screen and then select FireNET Setup > FireNET Settings. The 
following screen will be shown.  



FireNET graphix Manual, revision 2.1  Page 9 of 26 

2.2.1 Application tab options   

FireNET graphix Design project (.prj) 
This is used to select the site-specific project file. This file coordinates the various image files (maps), detection device 
icons and location information. The project file must be created using the FireNET graphix Designer application. 

FireNET graphix Design project - Find 
This can be used to browse for and load other projects as they are created. 

FireNET graphix Design project - PC port 
This is the PC COM port used to directly connect to the FireNET graphix Dongle installed in the FireNET control panel. 

Event Output Directory  
This is the location of the FireNET graphix event log files. This may be a local drive location or a remote server if 
required. 

FireNET graphix -NET Server Project (.svr) 
If the FireNET graphix Net option is being used to send event information and images to FireNET graphix Net client 
computers, then a site specific configuration file is required. This file is generated using the “FireNET graphix Server 
Designer” program and the target file is stored on the FireNET graphix computer or on the network server. 

Repeater Mode’s Remote Server Name 
The FireNET graphix program may be started as a main program (for the computer linked to the FireNET panel) or as a 
remote control workstation (repeater). The FireNET graphix workstation needs to be running on a workgroup or 
network whereby the workstation computer can access the computer running the main FireNET graphix program.  This 
menu option allows the main FireNET graphix computer name to be allocated so that the workstation can get the 
correct data to display and control the fire system 

START FireNET/NET 
This button starts the FireNET graphix program when it is connected to a control panel.  FireNET graphix will not start 
unless a panel connection is present and the correct security code has been entered. 

Start Simulation 
This button starts the currently loaded project in simulation mode.  The project can then be used without a panel 
connection for testing and demonstration purposes. 

Start Repeater 
This button starts FireNET graphix on a computer configured as a Workstation (repeater).  The workstation needs to 
be running on a workgroup or network whereby the workstation computer can access the computer running the main 
FireNET graphix program.  FireNET graphix will not start unless a panel connection is present and the correct security 
passcodes have been entered. 

STOP FireNET 
This button stops the FireNET graphix from running and is only available after successfully starting FireNET graphix. 

Synchronize time 
The time set on the PC can be sent to the panel to which the PC is connected (and all other fire panels if on a 
network). 
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2.2.2 Behaviour tab 

The main area of this tab is used to select how FireNET graphix responds to each of the available event types. 

Processes 
If this box is not checked these event types will not be displayed.  They can still be logged, printed and emailed. 

Logged to File 
If this box is not checked these events will not be logged to the event log file. 

Force Acceptance 
If this box is not checked an event that is cleared (by resetting the fire panel for example) will automatically clear from 
the event pane and will not need to be accepted. 

Prints 
If this box is checked events of this type will be printed to the default printer connected to the PC. 

Emails 
If this box is checked events will generate an email to be sent to selected recipients (see Graphics/Events tab for 
details). 

Nodes to ignore 
In a networked system, which may cover different buildings with different security centers, it may be advantageous to 
select all events from certain panels (nodes) to be ignored. The nodes to be ignored should be entered with comma 
separators i.e. 1,2,4  

Zones to Ignore 
It may be advantageous to ignore events from specific detection zones. Enter the zones to be ignored using commas 
to separate the entries.  
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Archive Event Log File 
The Event Log record is made of a number of files which are automatically created at regular intervals. The frequency 
at which a new file is created is selected using this option. This feature allows part of the event log to be archived by 
removing only the oldest files that are used to create the overall event log information. 

Analog Value Charting 
This setting allows the analog value of all sensors to be automatically recorded and saved for future evaluation. 

Printing Options 
When the “Print” behavior checkbox has been selected for an event type, then it is possible to select whether a screen 
shot showing the highlighted device is printed and / or whether the event text information is printed. There is also an 
option to add some specific text at the bottom of the printout, such as filing instructions.  

2.2.3 Graphics/Events tab 

2.2.3.1 Screen Layout Tab 

Map Background/Appearance 
This option allows the background color of the main display area to be selected from a pull-down menu of common 
colors.  The “Use Map Image Corner Colour” checkbox allows graphix to automatically select the color according to the 
corner color of the map image. The background color is only visible if the image files do not fill the full screen size. 

Show Device Address Labels 
Permanently displays the address label information for any detection devices visible on the selected map. If this is not 
selected the device information is only visible when the cursor is selected over the device icon. 
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Map Navigation Border Buttons 
If the site project file has been developed using navigation from one image to the next, then rather than use the 
“Navigate” button to open the navigation form, it is possible to click on the map border to move to the next image. For 
example, clicking on the left frame of the image will scroll to the next image west of the current one.  Select the 
checkbox to enable this feature. 

Navigation Transition Effects 
Selecting this option provides a smoother transition between map images when navigating between images 

Event Pane Layout 
The event pane is normally located on the left of the computer screen. However, it is possible to adjust the location of 
the event pane to the right or lower part of the computer screen.  Select the desired location using the radio buttons in 
the Layout section.  Changing this feature requires a restart of FireNET graphix run.exe. 

Mouse only / Touch screen 
When selected the FireNET graphix system will support a touch screen only option. In this mode, the virtual keyboard 
icon is present when logging into the FireNET graphix system and when accepting events, thus eliminating the use of a 
conventional keyboard for typing messages. 

Map Auto Scroll Time 
If more than one event is present and the events are on different maps, FireNET graphix can be configured to scroll 
between all active maps. This setting allows the scroll time to be set between 5 seconds and 1 minute.  Map scrolling 
may also be completely disabled by setting this option to OFF. 

Event Action Settings (Shown for all tab options) 
For each event type various graphics effects can be assigned using the following settings: 

Animation Speed 
When using animated icons, the speed of the animation may be selected 

Color schemes 
Schemes are selectable which change the colors and animations of each event type globally. 

Global event color 
The color of the animation surrounding an activated device can be changed. 

Event animation 
The animation effect surrounding an activated device can be changed. 

Active Appearance 
The highlighted icon may be selected to animate, flash or have a steady highlight 

Event Icon in Flashing Links 
This option will show the event type icon in the higher level images which only have links to the map where the event 
has occurred. These links will normally also be highlighted in the color of the event as well. 

Event actions 
This allows each event type to be selected for modification. 

Event Email Setup 
This allows one or more email addresses to be set up, allowing those events selected on the Behaviour tab to be 
emailed when they occur. 
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2.2.3.2 Events Action Tab  

On New Event 
Here it is possible to select if the event pane is automatically displayed when an event occurs. There is also an option 
to highlight a new event by means of crosshair lines when the event occurs. 

Change Current Map 
When a new event occurs there are options to determine the response of the FireNET graphix system. The choices are 
to zoom to the device, zoom to the map with the zone link of the zone in fire, keep the current image or revert to the 
top level site map image. 

Map Device Arrows 
Arrow from event to Device 
When a device is selected in the event pane, an arrow is automatically generated to point to the selected device. 

Arrow from Device Window to Device 
Clicking on a device icon will display the Device Details screen as is shown in section 2.1. If this checkbox is selected 
then an arrow is shown to highlight the selected icon. 

On Dongle Disconnect   
This allows the system to try to reconnect to the dongle every 5 seconds when selected 
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2.2.3.3 Event Grid/Thumbnails Tab 

Grid Columns 
This allows the user to configure what information is shown in the event pane columns. Three of the options can be 
selected / deselected. The fourth column (event timer column) can be configured to be either hidden, time of 
occurrence or the duration since the event occurred. 

Event pane width 
It is possible to configure the width of the event pane. This is occasionally required if large fonts are used in the event 
pane, or if unusual screen resolutions are configured. Manually clicking and dragging the event pane to the required 
width can set the configured width as the default.  
The Reset event pane width button restores the width to the default setting 

Event Timer Column 
This allows the timer column in the event pane tree view to be configured. This column can be configured to show 
nothing, or can be configured to show the event time of occurrence or time since the event occurred. The latter is 
useful in systems with delays to outputs, as it shows how much time since the event occurred and therefore how much 
time is left. 

Thumbnails 
This option allows a thumbnail image of every map in the project to be shown in a scrolling column to the right hand 
side of the screen. These thumbnails can be used to easily navigate to other maps if required 

Show Gridlines and Show Fire Event List 
‘Show Gridlines’ allows gridlines to be displayed between the grid columns in the event pane tree view.  ‘Show Fire 
Event List’ displays a list above the event pane tree view of all active fire alarm events. 
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2.2.3.4 Event Grid/Thumbnails Tab 

Fire Drill / Programmable Function 
It is possible to assign text to the function button in the Virtual FireNET panel screen. This can be useful if the button 
has been configured for a specific function. 
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2.2.4 Audio tab 
This Audio tab options allows different sounds to be assigned to each event type.  The sound can be selected to play 
once or repeat until the event is accepted. A useful source of sounds can be found within Windows® at 
C:\WINDOWS\Media. 

Any sound can be used including voice. Voice messages of up to 60 seconds long can be recorded using the Windows® 
sound recorder  

Each event type can be announced using either the selected wav file or by synthesized speech. If the speech option is 
required, type the message in the “Speech” message box. 
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2.2.5 Status Panels tab 

There are eight status panels (boxes) at the bottom of the main monitoring screen.  These can be used to indicate the 
status and real-time count of critical events such as Fire, Trouble, Pre Alarm and others.  Alternately, the status boxes 
can be used to display the status of up to 8 selected zones.  Select the desired zone from the pull-down menu. 

Status panel 3 is set to ‘Zone State’ for zone 12 
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2.2.6 Quiet Message tab 
This message will be displayed at the top of the side pane when FireNET graphix is connected to a control panel and 
the alarm system is in a normal state with no active events. 

2.2.7 About tab 
This window contains details about the version of FireNET graphix in use and PC system information. 

2.3 User Setup 

After the system is configured and installed it may be desirable to restrict some functions so that end users cannot 
change settings which could prevent proper system operation. 

Click on the FireNET button in the bottom left hand corner of the screen and then select FireNET Setup > User Setup.  
The window shown above will be displayed. 

The only user on a new installation is the Administrator. The Administrator can access all areas of the system. The 
administrator should add at least one new user and restrict administrative privileges by unchecking the Grant 
Permissions box.  Access to standard controls can then be set for the user according to requirements.  You may also 
want to change the administrator password from the default; if you do so, be sure to keep an accurate record of the 
new password.  There is no way to access administrator options without an administrator-level password! 

Several users with their own passwords can be added with differing access to standard controls if needed. 
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2.4 Security Code 

To enter the dongle security code, click on the FireNET button in the bottom left hand corner of the screen.  Select 
FireNET Setup > Security Code.  The window seen below will appear. 

Click on the Read Dongle Code button.  If the dongle is new (i.e. it has not been read before) a Get New Dongle Code 
button will appear.  Click this button.  A code number will be displayed.  The number can be copied to the clipboard so 
that it can be printed, or the number can be pasted into an email and sent directly to Hochiki America Corporation. 
The sales department at Hochiki America will use this code to generate an unlock code which can be given to you over 
the telephone or emailed back. 

After you have received the unlock code from Hochiki America, restart the Security Code Wizard and click the 
Authorize Code button to enter the unlock code.  Click the Next button and then type or paste the code number 
received from Hochiki America into the window labeled ‘Enter New Code’. Click Authorize to complete the process.  A 
summary will appear at the bottom of the screen showing the number of panels and workstations unlocked for this 
project.  The dongle is now authorized for use with this installation. 

2.5 FireNET graphix Service 

Click the FireNET button in the bottom left hand corner of the screen and select FireNET Service. Four options are 
presented. 

Start FireNET Service 
This will start FireNET graphix in normal running mode but only when connected to a control panel with the dongle 
code enabled.  Starting the FireNET graphix Service when not connected to a control panel or with an incorrect dongle 
code will result in an error message. 

Start Simulation Mode 
This will start FireNET graphix in simulation mode as described in section 2.1, Running FireNET graphix. 

Start Repeater Service 
This option is used to start a PC that is operating as a workstation. 

Stop Active Service Mode 
This will stop the FireNET graphix service.  The PC cannot report events from the FireNET network when the service is 
stopped.  The PC screen will indicate that the system is offline. 
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2.6 View Maps 

Click the FireNET button in the bottom left hand corner of the screen and select Screen > View Maps.  This will show 
the list of maps in the currently loaded project. Selecting a map from the list will display it in the main display area of 
the screen.  Clicking on any zones that have links to other maps will display any linked maps. This can be useful for 
checking that map links are working as required. 

2.7 View Loop Devices  
(Also available via “Devices” button at the top of the main screen) 

Click the FireNET button in the bottom left hand corner of the screen and select Screen > View Loop Devices.  All 
devices in the current project will be displayed in a resizable table format window as follows: 

Device icon 
Device type 
Address 
Node (panel to which the device is connected) 
Loop 
Zone 
Location text 
State (normal/activated) 
Disabled (with a button to disable if FireNET graphix is running) 
Base sounder installed 
Analog value of device (if FireNET graphix is running) 
Maps on which the device is located 

To locate a device on the map, highlight the device in the table and click on the ‘Find Device on Map’ button at the 
bottom of the screen.  There are also buttons to view the Zone table (see below) and to read the analog values from 
the sensors.  To close the window, click on the Close Window button at the bottom of the screen. 

2.8 View Zones 
(Also available via “Zones” button at the top of the main screen) 

Click the FireNET button in the bottom left hand corner of the screen and select Screen > View Zones.  All zones in the 
current project will be displayed in a resizable table format window, with details about the state of each zone.  All 
zones except zone 0 can be disabled or enabled from this window.  To close the window, click on the Close Window 
button at the bottom of the screen. 

2.9 Print Current Event 

Click the FireNET button in the bottom left hand corner of the screen and select Events > Print Current Event.  By 
selecting Print Current Event, an active event can be sent to the default printer. To print other active events, select 
them on the event pane and then select Print Current Event again from the Events menu. 

2.10 Event Log 
(Also available via Event log button at top of main screen) 

Click the FireNET button in the bottom left hand corner of the screen and select Events > View Event Log.  The event 
log can be displayed in HTML format or in a text list view.  The log can be saved to disk, printed, or emailed by using 
the buttons at the top of the window. 

The event log can be filtered by event type, user, date, node, loop, zone, address or device type, or any combination 
of these. This powerful filter helps produce data which can be analyzed to track down repeated activations and is a 
valuable tool in the fight against false alarms. 

2.11 Map Windows 

Click the FireNET button in the bottom left hand corner of the screen and select Screen > Map Windows. Three 
additional options are presented. 
Tile Horizontally 
Displays all active maps on the screen horizontally. 
Tile Vertically 
Displays all active maps on the screen vertically. 
Cascade 
Displays all active maps on the screen one on top of the other. 
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2.12 Minimize 

Click the FireNET button in the bottom left hand corner of the screen and select Screen > Minimize.  Two options are 
available; Minimize FireNET and Minimize FireNET with SysTray Status.  Both options allow FireNET graphix to be 
minimized, so that other applications can be used.  If the second option is selected, events status and event count will 
be displayed in the system tray on the PC display. 

To maximize FireNET graphix, double click on the gray box near the Windows Start button. 

2.13 Log off Administrator 
(Also available via Log Out button at the bottom right corner of the main screen) 

Click the FireNET button in the bottom left hand corner of the screen and select Log off Administrator.  This logs the 
user out and presents the FireNET graphix Logon box to allow other users to log on. 

2.14 Shutdown FireNET 

Click the FireNET button in the bottom left hand corner of the screen and select Shutdown FireNET.  This action will 
shut down the FireNET graphix application. 

2.15 Event Pane 

To supplement information displayed by way of maps, diagrams or photographs, an event pane appears whenever an 
event is activated.  The top of the event pane shows the event type and other details about the event, including the 
node, loop and address of the device that had generated the event. 

Below the main event pane window is a window that displays current events. These events can be accepted 
individually by selecting the event and clicking on the Accept button.  A text box is located below the Accept button. 
This box allows the user to enter additional details about the event before it is accepted.  These details will be 
recorded in the event log for reference.  There is also a button that allows the user to accept all events, and a button 
that allows the user to select any map that they wish to view.   

3.0 Designer   

Before a FireNET graphix design project can be created you should have a Loop Explorer .lex or .lx2 file.  Loop 
Explorer is the software program used for configuring FireNET control panels.  A .lex or .lx2 file can be created in Loop 
Explorer by selecting File > Export Loop Explorer Config > FireNET graphix.  Loop Explorer will create the appropriate 
file to be used with graphix. 

You will also need the maps that are to be included in the project.  Supported map formats include .jpg, .bmp, .gif and 
.avi.  You may use the BMP Grabber utility to convert .dwg and .dxf files into bitmap format.  See section 4.0 of this 
manual for details about the BMP Grabber utility 

NOTE: Planning your project – It is typical for buildings to be divided into zones, with detectors and other devices 
installed in each zone.  Each installation will be organized differently, based on building layout, local requirements and 
other factors.  The Loop Explorer export file will provide all device and zone information to FireNET Designer.  You can 
draw the zones onto the maps while designing your graphix project, but you must know how the zones are actually 
laid out in the building(s).  As-builts may be helpful in this regard.  

To start the Designer program click the Windows start button, then select Programs > FireNET graphix > 
Designer.exe. You may start a new project or open an existing project. 

To begin a new project, click on the ‘Start New FireNET Project’ radio button, and then click OK.  Enter a project name 
and save the project to a location where it can easily be found later.  The FireNET Designer Wizard will be displayed. 

The Designer Wizard will prompt you through the steps of creating a project.  The first step is to add the maps.  The 
Map Wizard will help you choose your maps for the project and select the main site map.  The main site map is usually 
a map that shows an overall view of the building or site, and is the default image seen when FireNET graphix is in a 
normal state with no active events.   

After choosing the maps, you must select the .lex or .lx2 export file from Loop Explorer.  This file will tell FireNET 
Designer how may panels and devices you have on the system.  Other things such as zone assignments and device 
text will also be included in the Loop Explorer export file. 

After selecting the maps and export file, the Designer Wizard will present some additional options that allow you to 
add devices to the maps and resize the maps to fit the PC monitor.  Note that these options can also be performed 
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later as the project is being completed.  Design Manager also includes a brief tutorial that explains how to add 
navigation links to your project.  This tutorial is also available for viewing on the Design Manager Help menu. 

After the Designer Wizard closes, the main design screen will be displayed showing the main site map with Project 
Navigator and Network Navigator on the left. 

Each of the maps can now be viewed by selecting them from the Project Navigator window on the left of the screen. 
The fire alarm devices that were imported from the .lex/.lx2 file can be viewed by expanding the control panel icon in 
the Network Navigator window below the Project Navigator window. 

3.1 Map Options 

Select a map from Project Navigator list.  When the map is displayed, right clicking it will display a menu from which 
Background Map Properties can be selected.  

From the Map Details tab, the name of the map can be changed, a different map can be selected, the map can be 
shown in Negative Image or gray scale, or the map can be edited by selecting Edit Picture.  This will load FireNET Draw 
or Windows Paint, depending on file type.  FireNET Draw is a simple picture-editing tool (Select File > Exit to exit the 
picture editor). 

The Navigation tab allows you to link this map with other maps in the project.  Click on the Setup Navigation button 
and a screen will be displayed showing the current map and North/South/East/West/Up/Down navigation options.  By 
linking the current map to other maps, you can navigate by clicking the Navigate button in FireNET run.exe and 
selecting the desired direction (see section 2.1 of this manual for more details on the Navigate button).  

The Map Size tab allows the map to be re-sized for the best fit on the screen. The ‘Lock’ check box, when selected, will 
keep the proportions of the map consistent when resizing it. 

The Grid Size/Nudge tab allows a grid to be displayed from 4 to 80 pixel spacing by adjusting the Grid Spacing slider. 
The Snap to Grid check box gives the option to have the devices snap to this grid when placed on the map.  The Icon 
Nudge Distance can also be set between 1 and 50 pixels using the slider.  Icon Nudge distance is the distance an icon 
will move when nudged using the icon tools on the toolbar that runs vertically up the screen. 

3.2 Working with Map Links 

Map Links 
Map links are used to allow zooming in or out to show more or less detail. For example, FireNET graphix may be 
monitoring a number of buildings on a large, widely spread out site as is found in some hospital complexes.  In this 
example the main site map would ideally be a map showing the whole site including individual buildings being 
monitored.  Each of those buildings could have a link to it on the main map which, when clicked, would display an 
overall plan of the building. It may be that the building is too large to show the detail that is needed in a fire situation 
so further links to more detailed areas of the building may be added.  A button at the top of the run.exe screen labeled 
Site Map allows navigation back to the main site map. 

To set up a map link select New Link from the right-hand toolbar and click on an area of the map. See the FireNET 
Designer help on how to create links for more details (Help > How to Create Links). 

After the link has been created using the ‘New Link’ option, a link Options window will be displayed.  The link can be 
configured to point to a specific map (Link Options tab), or a link can be associated with a zone (Zones tab).  The 
Properties tab allows you to configure the color and event behavior of the link.  These options can be accessed at any 
time by selecting the link on the map, right-clicking it and then selecting ‘Properties’.  To test the link, select it and 
right-click to display the menu selections.  The ‘Test Map Link (Navigate)’ option will allow you to confirm that the link 
will work as desired.  After navigating to the linked map, there will be a ‘Back’ button at the top of the screen that 
allows you to easily return to the map you are working on.  

Transformations 
Links that have been drawn can be modified by selecting the link, right clicking on it, and selecting Transformations 
from the right-click menu. This allows the link to be placed in front of or behind other zone areas or flipped horizontally 
or vertically. 

Lock 
Links that are complete and require no further modification can be locked against further editing by selecting Lock 
from the right click menu (Locking > Lock).  They can also be unlocked by selecting Unlock from this menu. 

Copy 
Links that are the same size and shape can be produced very quickly by drawing one and then duplicating it.  Select 
the link and then choose ‘Copy’ from the right-click menu.  Links can also be copied to other maps by selecting ‘Copy 
to Maps’.  Duplicate links can be modified if required by selecting Properties from the right-click’ menu. 
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Delete 
Links can be deleted by selecting them, right clicking and selecting Delete. 

3.3 Adding Devices to Maps 

The Network Navigator on the bottom-left of the screen shows all of the control panels on the fire alarm panel 
network.  There are three tabs at the bottom of the Network Navigator; Connection, By Zone, and Zoom.  The 
‘Connection’ tab shows all devices as they are physically connected, by panel and loop.  The ‘By Zone’ tab shows all of 
the devices sorted into zones.  The zone assignment is determined by the Loop Explorer export file and cannot be 
changed in Designer. 

The Zoom tab allows you to zoom in on the map for detail work. 

If you chose to add devices to the maps when using the Designer Wizard, you will see devices already placed on the 
maps.  If you chose not to add the devices using the Designer Wizard, you can add them now by clicking on a device 
in the Network Navigator tree.  While holding down the mouse button, drag the device to the appropriate location on 
the map and then release the mouse button.  The device can be moved again by clicking on it and using the same 
drag-and-drop technique.  Devices should be added to indicate their actual location in the building; for that reason, 
they are usually added to the more detailed “lower level” maps.  

If your maps have been divided into zones (perhaps with zone links added), you may find it easier to add devices 
using the ‘By Zone’ view, rather than the ‘Connection’ view.   

You can select multiple devices by holding the CTRL or Shift key on the keyboard and clicking on multiple devices.  You 
can then drag and drop them onto the map. 

A device can be nudged in one of four directions to position it more accurately.  Select the device by clicking on it, and 
then select Devices > Selected Devices (Current Map) > Nudge Selected from the toolbar.  You will have the option to 
nudge the device Up, Down, Right or Left.  Right clicking on the map and selecting Background Map Properties will 
allow you to adjust the Icon Nudge Distance for the map.  

After the device has been placed, the icon can be changed or edited by highlighting it and right clicking it.  Select ‘Icon 
Options’ to make changes to the icon appearance and size.  Each icon can also have a specific message added in 
addition to the standard event messages.  A device icon can also be deleted from a map by means of the right-click 
menu. 

After placement, each device will be shown as bold on the Network Navigator list indicating that it has been placed. 
Repeat this procedure for all devices in all zones on all maps until all of the items in Network Navigator are shown in 
bold. 

Zone text 
Zone text can be added to the zones by clicking on the Zone Text button on the toolbar. 

User Icons 
The icons available have been designed to suit the needs of most fire systems.  The standard icon for any device type 
can be changed by selecting the device, right clicking it and selecting ‘Icon Options’ from the menu.  This allows the 
default icon to be changed to any of the Standard Icons on the list or re-sized.  User Defined Icons can also be added 
to the project (Devices > User Defined Icons).  This opens up the possibility of using any icon you wish for your 
project.  You must create and save your user defined icon before it can be used.  FireNET Icon Editor can be used to 
create new icons or modify existing bitmap icons for use with your project (File > FireNET Icon Editor).  

Messages 

Standard event messages  
FireNET graphix does not have to display maps or floor plans.  Each event activation will display a message window, 
which contains the event type, node, zone, loop, address, and location text as standard.  Additional text can be added 
for each event type. This may include instructions on what to do when an event of a particular type occurs, contact 
telephone numbers or anything else that may be deemed suitable for the particular installation. 

To access the message window click the Messages button on the top toolbar.  The left hand side of the screen allows 
the event type to be selected.   

The Message Header is the message that will be displayed when the selected event takes place (for example, Fire). 
This text may be changed if required. 

The Message Body is the information received from the control panel. The content of this message cannot be changed 
but the font, style and color can be changed by selecting the Set Font button within the message body window. 

The Message Suffix is used for additional information that may be required such as instructions on emergency 
procedure. The font size, style and color can be changed by using the text formatting tools on the toolbar or on the 
right-click menu. 
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Specific user messages 
The ‘Specific User Messages’ tab allows additional custom text to be added which will appear after the message suffix. 
When adding a Specific user message it helps to make the message name the same as the address of the device e.g. 
Node 1 Loop 2, address 12.  When allocating Specific user messages (right click on a device icon then select Icon 
Options > Event Message Text) the message can then be searched for by its address. 

3.4 Toolbars 

Right Toolbar 

Select 
The Select tool at the top of the left hand side toolbar switches off the ‘New Link’ or ‘New Button’ mode and sets the 
map window cursor to a cross hair (unless over an icon, link or button).  This enables device selection, movement and 
editing. 

New Link 
Toggle button which, when on, allows new links to be drawn and created on the map.  The ‘Drawing Shape’ pull-down 
menu allows you to select from different drawing options when creating a link.  For more details on the different 
drawing shapes, see the help topic “How to Create Links” in FireNET Designer.   

Add Nodes 
The button allows additional handles to be added to link shapes for creating polygons. Additional nodes must be added 
between the two green nodes show on a selected zone shape.  Click the ‘Add Nodes’ button to turn it off. 

Move Mode 
When the ‘Move Mode’ radio button is selected, the selected link may be relocated on the map.  Move Mode also allows 
you to adjust the link shape by moving one or more nodes on the link. 

Scale Mode 
When the ‘Scale Mode’ radio button is selected, the selected link may be resized or rotated. 

Show Invisible Links 
If one or more links have been configured as invisible, selecting this option will allow you to see where the invisible 
links are located on the map. 

Top Toolbar 

Lock Icons 
Toggle button which locks icons to the map, preventing them from being moved accidentally. 

Link View 
This tool allows you to review the navigational links for a project.  

Save 
Saves the current project to the specified location. 

Properties 
Displays the properties for the item selected in the Project Navigator. 

New Map 
Allows new maps to be imported and added to the Project Navigator. 
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4.0 BMPGrabber 

This simple utility allows CAD drawings in .dxf or .dwg format to be imported and sections of the drawing to be 
zoomed into (or out of) and saved in .bmp format for use within FireNET graphix Designer. 

To use the BMP Grabber utility, click on the Windows start button and select Programs > FireNET graphix > 
BMPGrabber.  Select the .dwg or .dxf file you wish to use and click Open.  Choose the editing style you wish to use 
(Convert To Vector or Convert To Bitmap) by clicking on the appropriate button. 

Using the View menu options or the buttons at the bottom right of the image window, you can zoom in or out of the 
image.  If you chose to convert to vector, you can select the arrow tool (zoom last) and draw around the section of the 
drawing to be enlarged while holding the mouse button down. This area will now appear enlarged. To restore the 
image press the button with the grey filled square (zoom reset).  Both of these buttons appear in the bottom right-
hand corner of the window.  By zooming in this way, sections of a CAD drawing (one building of a site plan for 
example) can be enlarged and created as a map image. 

Once the desired section of the drawing has been selected, the size of the drawing can be enlarged by clicking Edit > 
Set Window Size.  The background color of a vector drawing can be changed by clicking Edit > Background Color. 
The line thickness of the drawing (vector) can be changed by clicking Edit > Vector: Thickness 1, Thickness 2 or 
Thickness 3.  If you chose to convert to bitmap, you can rotate or flip the image by selecting the appropriate option 
from the Edit menu. 

When the image appears as required in the FireNET graphix designer program, select File > Save Current View As 
Image.  You can save the file as a .BMP or .JPEG Image.  Give the file an appropriate name and save it to a location 
where it can be easily found later. 

When the image is opened in the FireNET Designer program, it will appear at the same size and proportions as it did 
when saved in BMP grabber.  If necessary, the size and proportions of the image can be further modified from within 
the designer program by right clicking the map and choosing Background Map Options. 



FireNET graphix Manual, revision 2.1  Page 26 of 26 

Hochiki America Corporation 
7051 Village Drive, Suite 100 
Buena Park, CA 90621-2268 

(714) 522-2246 Main  
(800) 845-6692 Technical Support 

http://www.hochiki.com 
technicalsupport@hochiki.com 

End of Manual 
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